Cisco UCS: Unified Computing System
The Cisco Unified Computing System (Cisco UCS) is a comprehensive compute resource system that integrates servers, networking, and I/O into a single intelligent platform.
Cloud computing
Cloud computing is the on-demand delivery of compute power, database storage, applications, and other IT resources through a cloud services platform through the internet with pay-as-you-go pricing.
Cloud Computing is a model for enabling omnipresent, convenient, on-demand network access to a shared pool of configurable computing resources (e.g., networks, servers, storage, applications, and services) that can be rapidly provisioned and released with minimal management effort or service provider interaction.
Cloud Computing is a model for enabling omnipresent, convenient, on-demand network access to a shared pool of configurable computing resources (e.g., networks, servers, storage, applications, and services) that can be rapidly provisioned and released with minimal management effort or service provider interaction.
Cisco IOS: Configuration and troubleshooting
Cisco Internetwork Operating System is a command line method of configuring a Cisco device. This is software that is consistent through nearly all Cisco devices. Learn it once, and use it on any Cisco equipment, switch or router.
Have the following settings on your terminal:
Baud rate : 9600
Data bits : 8
Parity : None
Stop bits : 1
Flow Control : None
Switch # ? for help
Switch # c? For all commands that start with the letter c
Switch # clock set ?
Switch # clock set 13:16:35 Sept 15 2013
Switch # configure terminal OR conf t
Switch > User mode
Switch > enable
Password:
Switch # Privileged mode
Switch # conf t
Switch(config) # Global configuration mode
Initial configuration of the switch:
Flash memory : IOS stored
64 MB memory
NVRAM —> configuration stored
IP address for the switch
Switch # conf t
Switch(config) # interface vlan 1
Switch(config-if) # ip address 10.149.73.71 255.255.254.0
Switch(config-if) # no shutdown
Switch(config-if) # ip default-gateway 10.149.72.1
Switch(config-if) # exit
Switch(config) # exit
Switch # copy running-config startup-config OR copy run star
This copies the configuration information from the running config to the startup config.
# show version
Passwords
Switch > enable
Switch # enable password <cleartext>
Switch # enable secret <encrypted text>
To remove the enable password,
Switch # no enable password
Line configuration mode
Switch # conf t
Switch(config) # line console 0
Switch(config) # password <something>
Switch(config) # login
For telnet access
Switch # conf t
Switch(config) # line vty 0 4
Switch(config-line) # no login
To convert clear text passwords to encrypted format
Switch # service password-encryption Level 7 encryption, this is not very secure
Better to go for MD5 authentication
Message of the day
Switch # banner motd <whatever message>
Setting up SSH on a Cisco switch
Switch # username admin password octagon123
Switch # ip domain-name www.company.com
Switch # crypto key generate rsa <Return key)
How many bits in the modulus [512]: 1024
Switch # ip ssh version 2
Switch # line vty 0 4
Switch(config-line) # transport input ssh
Configuring port security
Switch # show ip int brief
Switch # terminal monitor
Switch # conf t
Switch(config) # int GigabitEthernet 1/27
Switch(config-if) # switchport mode access
Switch(config-if) # switchport port-security maximum 1
Switch(config-if) # switchport port-security violation shutdown | restrict | protect
Switch(config-if) # switchport port-security mac-address 0014.314a.bcef
Switch(config-if) # switchport port-security mac-address sticky <—— calculated risk
Switch(config-if) # exit
Switch(config) # exit
Switch # copy run star
Switch # show port-security int GigabitEthernet 1/27 <—————— Useful for say Lobby ports
Observe Security Violation Count : 0 or 1 or 2
Some useful configuration and troubleshooting commands
Have the following settings on your terminal:
Baud rate : 9600
Data bits : 8
Parity : None
Stop bits : 1
Flow Control : None
Switch # ? for help
Switch # c? For all commands that start with the letter c
Switch # clock set ?
Switch # clock set 13:16:35 Sept 15 2013
Switch # configure terminal OR conf t
Switch > User mode
Switch > enable
Password:
Switch # Privileged mode
Switch # conf t
Switch(config) # Global configuration mode
Initial configuration of the switch:
Flash memory : IOS stored
64 MB memory
NVRAM —> configuration stored
IP address for the switch
Switch # conf t
Switch(config) # interface vlan 1
Switch(config-if) # ip address 10.149.73.71 255.255.254.0
Switch(config-if) # no shutdown
Switch(config-if) # ip default-gateway 10.149.72.1
Switch(config-if) # exit
Switch(config) # exit
Switch # copy running-config startup-config OR copy run star
This copies the configuration information from the running config to the startup config.
# show version
Passwords
Switch > enable
Switch # enable password <cleartext>
Switch # enable secret <encrypted text>
To remove the enable password,
Switch # no enable password
Line configuration mode
Switch # conf t
Switch(config) # line console 0
Switch(config) # password <something>
Switch(config) # login
For telnet access
Switch # conf t
Switch(config) # line vty 0 4
Switch(config-line) # no login
To convert clear text passwords to encrypted format
Switch # service password-encryption Level 7 encryption, this is not very secure
Better to go for MD5 authentication
Message of the day
Switch # banner motd <whatever message>
Setting up SSH on a Cisco switch
Switch # username admin password octagon123
Switch # ip domain-name www.company.com
Switch # crypto key generate rsa <Return key)
How many bits in the modulus [512]: 1024
Switch # ip ssh version 2
Switch # line vty 0 4
Switch(config-line) # transport input ssh
Configuring port security
Switch # show ip int brief
Switch # terminal monitor
Switch # conf t
Switch(config) # int GigabitEthernet 1/27
Switch(config-if) # switchport mode access
Switch(config-if) # switchport port-security maximum 1
Switch(config-if) # switchport port-security violation shutdown | restrict | protect
Switch(config-if) # switchport port-security mac-address 0014.314a.bcef
Switch(config-if) # switchport port-security mac-address sticky <—— calculated risk
Switch(config-if) # exit
Switch(config) # exit
Switch # copy run star
Switch # show port-security int GigabitEthernet 1/27 <—————— Useful for say Lobby ports
Observe Security Violation Count : 0 or 1 or 2
Some useful configuration and troubleshooting commands
show processes cpu
show processes cpu | include Check heaps
traceroute mac source_MAC_address destination_MAC_address
show ip cef
show ip cef 192.168.1.11
show adjacency
show adjacency detail
show ip arp
show controllers cpu-interface
show ip cache flow
show ip route 172.16.0.0 255.255.0.0 longer-prefixes
show ip route profile
show tcp statistics
show ip inspect session
show ip inspect session detail
show ip inspect all
show ip nat translations
show ip nat statistics
show class-map
show policy-map
show ipv6 route
show mac address-table
show mac address-table security
show mac-address-table dynamic
show mac address-table dynamic vlan <VLAN-ID>
show mac address-table security
show mac-address-table dynamic
show mac address-table dynamic vlan <VLAN-ID>
show mac address-table interface <Interface>
show interfaces trunk
show interfaces trunk
show interfaces switchport
show vlan
show vlan brief
show vlan id <VLAN-ID>
show vtp
show vlan-membership
show vlan all-ports
show vlan access-log config
show vlan access-log statistics
show vlan access-log flow
show vlan
show vlan brief
show vlan id <VLAN-ID>
show vtp
show vlan-membership
show vlan all-ports
show vlan access-log config
show vlan access-log statistics
show vlan access-log flow
RHEV: Red Hat Enterprise Virtualization --- System Administration
yum install rhevm-cli
rhevm-shell
[RHEVM shell (connected)] # show vm --name
[RHEVM shell (connected)] # shell ls -altr
[RHEVM shell (connected)] # list vms --show-all
[RHEVM shell (connected)] # show vm --name desktop_vms
[RHEVM shell (connected)] # help show
[RHEVM shell (connected)] # list datacenters
[RHEVM shell (connected)] # list clusters
[RHEVM shell (connected)] # list networks --show-all
[RHEVM shell (connected)] # add host --name Host12345 --address host12345.company.com --root_password <password>
[RHEVM shell (connected)] # action host Host12345 activate
[RHEVM shell (connected)] # add storagedomain --name DataStorage --host-name Host12345 --type data --storage-type nfs --format v1 --storage-address '<IP-address>' --storage-path /exports/data --datacenter-identifier Default
[RHEVM shell (connected)] # action storagedomain DataStorage
[RHEVM shell (connected)] # add vm --name VM12345 --cluster-name Default --template-name Blank --memory 33554432 --os-boot-dev hd
[RHEVM shell (connected)] # add nic --vm-identifier VM12345 --name nic1 --network-name rhevm --bootable true
[RHEVM shell (connected)] # add disk --vm-identifier VM12345 --provisioned_size 8589934592 --interface virtio --format cow
[RHEVM shell (connected)] # console VM12345
[RHEVM shell (connected)] # list vms
[RHEVM shell (connected)] # list vms --show-all
[RHEVM shell (connected)] # list vms --query "status=up"
[RHEVM shell (connected)] # list vms --query "name=VM12345"
[RHEVM shell (connected)] # show vm fdcab281-9c42-4a0e-bcd4-92cdef76ab3c
[RHEVM shell (connected)] # show vm VM12345
[RHEVM shell (connected)] # status
[RHEVM shell (connected)] # summary
cat /var/log/vdsm/mom.log for the Memory Overcommit Manager log.
vi /etc/sysconfig/network and
vi /etc/sysconfig/network-scripts/ifcfg-rhevm for configuring the network interface.
service network restart for RHEL 6
ifconfig rhevm for RHEL 6
systemctl restart network.service for RHEL 7
ip addr show rhevm for RHEL 7
hostnamectl set-hostname <FQDN>
/etc/ovirt-engine/ovirt-fence-kdump-listener.conf.d : Location for creating a new listener file
service ovirt-fence-kdump-listener restart
service ovirt-engine restart
Configuring NFS
---------------------
yum install nfs-utils
chkconfig --add rpcbind
chkconfig --add nfs
chkconfig rpcbind on
chkconfig nfs on
service rpcbind start
service nfs start
mkdir -p /exports/<data>
mkdir -p /exports/<export>
exportfs -r
service nfs reload
groupadd kvm -g 36
useradd vdsm -u 36 -g 36
chown -R 36:36 /exports/<data>
chown -R 36:36 /exports/<export>
chown 0755 /exports/<data>
chown 0755 /exports/<export>
Remote Viewer on Linux
-------------------------------
yum install spice-xpi
rpm -q virt-viewer
yum install virt-viewer
Restart your browser.
General commands
-----------------------
ksmctl --> Kernel Same Page Merging
ksmctl info
ksmctl start <n pages>
ksmctl stop
ntpdate <server>
hwclock -w
hwclock --systohc
service ovirt-engine status
service ovirt-engine restart
rhevm-config
guestfish
virt-v2v
virt-sysprep --list-operations
rhevm-manage-domains -action=list
rhevm-log-collector list
rhevm-log-collector collect
rhevm-setup
rhevm-upgrade
rhevm-reports-setup
rhevm-shell -h
service NetworkManager start/stop/status
chkconfig NetworkManager on/off
service network restart
chkconfig network on
vdsClient list
vdsClient getAllVmStats
vdsClient getVdsStats
vdsClient getVdsCapabilities
vdsClient activateStorageDomain
vdsClient changeCD
vdsClient desktopLogoff
vdsClient getAllTasksInfo
vdsClient clearTask
vdsClient getIsoList
vdsClient getStorageDomainInfo
ip addr show
yum repolist
rhevm-dwh-setup
ip addr show dev rhevm
cat /etc/sysconfig/rhn/systemid
rhevm-shell
[RHEVM shell (connected)] # show vm --name
[RHEVM shell (connected)] # shell ls -altr
[RHEVM shell (connected)] # list vms --show-all
[RHEVM shell (connected)] # show vm --name desktop_vms
[RHEVM shell (connected)] # help show
[RHEVM shell (connected)] # list datacenters
[RHEVM shell (connected)] # list clusters
[RHEVM shell (connected)] # list networks --show-all
[RHEVM shell (connected)] # add host --name Host12345 --address host12345.company.com --root_password <password>
[RHEVM shell (connected)] # action host Host12345 activate
[RHEVM shell (connected)] # add storagedomain --name DataStorage --host-name Host12345 --type data --storage-type nfs --format v1 --storage-address '<IP-address>' --storage-path /exports/data --datacenter-identifier Default
[RHEVM shell (connected)] # action storagedomain DataStorage
[RHEVM shell (connected)] # add vm --name VM12345 --cluster-name Default --template-name Blank --memory 33554432 --os-boot-dev hd
[RHEVM shell (connected)] # add nic --vm-identifier VM12345 --name nic1 --network-name rhevm --bootable true
[RHEVM shell (connected)] # add disk --vm-identifier VM12345 --provisioned_size 8589934592 --interface virtio --format cow
[RHEVM shell (connected)] # console VM12345
[RHEVM shell (connected)] # list vms
[RHEVM shell (connected)] # list vms --show-all
[RHEVM shell (connected)] # list vms --query "status=up"
[RHEVM shell (connected)] # list vms --query "name=VM12345"
[RHEVM shell (connected)] # show vm fdcab281-9c42-4a0e-bcd4-92cdef76ab3c
[RHEVM shell (connected)] # show vm VM12345
[RHEVM shell (connected)] # status
[RHEVM shell (connected)] # summary
cat /var/log/vdsm/mom.log for the Memory Overcommit Manager log.
vi /etc/sysconfig/network and
vi /etc/sysconfig/network-scripts/ifcfg-rhevm for configuring the network interface.
service network restart for RHEL 6
ifconfig rhevm for RHEL 6
systemctl restart network.service for RHEL 7
ip addr show rhevm for RHEL 7
hostnamectl set-hostname <FQDN>
/etc/ovirt-engine/ovirt-fence-kdump-listener.conf.d : Location for creating a new listener file
service ovirt-fence-kdump-listener restart
service ovirt-engine restart
Configuring NFS
---------------------
yum install nfs-utils
chkconfig --add rpcbind
chkconfig --add nfs
chkconfig rpcbind on
chkconfig nfs on
service rpcbind start
service nfs start
mkdir -p /exports/<data>
mkdir -p /exports/<export>
exportfs -r
service nfs reload
groupadd kvm -g 36
useradd vdsm -u 36 -g 36
chown -R 36:36 /exports/<data>
chown -R 36:36 /exports/<export>
chown 0755 /exports/<data>
chown 0755 /exports/<export>
Remote Viewer on Linux
-------------------------------
yum install spice-xpi
rpm -q virt-viewer
yum install virt-viewer
Restart your browser.
General commands
-----------------------
ksmctl --> Kernel Same Page Merging
ksmctl info
ksmctl start <n pages>
ksmctl stop
ntpdate <server>
hwclock -w
hwclock --systohc
service ovirt-engine status
service ovirt-engine restart
rhevm-config
guestfish
virt-v2v
virt-sysprep --list-operations
rhevm-manage-domains -action=list
rhevm-log-collector list
rhevm-log-collector collect
rhevm-setup
rhevm-upgrade
rhevm-reports-setup
rhevm-shell -h
service NetworkManager start/stop/status
chkconfig NetworkManager on/off
service network restart
chkconfig network on
vdsClient list
vdsClient getAllVmStats
vdsClient getVdsStats
vdsClient getVdsCapabilities
vdsClient activateStorageDomain
vdsClient changeCD
vdsClient desktopLogoff
vdsClient getAllTasksInfo
vdsClient clearTask
vdsClient getIsoList
vdsClient getStorageDomainInfo
ip addr show
yum repolist
rhevm-dwh-setup
ip addr show dev rhevm
cat /etc/sysconfig/rhn/systemid
XTremIO
show-clusters
show-daes cluster-id=3
show-clusters-performance cluster-id=3
show-storage-controllers-infiniband-ports cluster-id=3
show-infiniband-switches-ports cluster-id=3
show-daes-controllers cluster-id=3
show-daes-psus cluster-id=3
show-daes cluster-id=3
show-volumes cluster-id=3
show-initiator-groups cluster-id=3
show-volume vol-id=”<Volume Name>” cluster-id=3
show-ssds cluster-id=3
show-ssds-performance cluster-id=3
show-ssds-diagnostics cluster-id=3 (Only for “tech” login)
show-leds
show-initiators
show-targets-performance
Ansible: a Configuration Management tool
apache.yml
---
- hosts: web
tasks:
- name: deploy apache
yum: pkg-httpd state=latest
- name: apache config file
copy: src='files/httpd.conf' dest='/etc/httpd/conf/httpd.conf'
notify:
- restart httpd
- name: apache service runs
service: name-httpd state=started
handlers:
- name: restart httpd
service: name=httpd state=restarted
Adding NTP deployment tasks to /etc/ansible/roles/web/tasks.main.yml
---
- include_vars: "{{ ansible_os_family }}.yml"
- name: Deploy Apache for Red Hat systems
yum: pkg-httpd state=latest
when: ansible_os_family' == 'RedHat'
- name: Deploy Apache for Debian systems
apt: pkg=apache2 state=latest
when: ansible_os_family == 'Debian'
- name: Apache Config File
copy: src={{ conffile }} dest={{ confpath }}
notify:
- config file update
- name: Apache Service Runs
service: name={{ webserver }} state=started
- name: Deploy NTP on Ubuntu servers
apt: pkg=ntp state=latest
when: ansible_os_family == 'Debian'
- name: Deploy NTP for Red Hat systems
yum: pkg=ntp state=latest
when: ansible_os_family == 'RedHat'
- name: NTP Service Runs
service: name={{ ntpserver }} state=started
---
- hosts: web
tasks:
- name: deploy apache
yum: pkg-httpd state=latest
- name: apache config file
copy: src='files/httpd.conf' dest='/etc/httpd/conf/httpd.conf'
notify:
- restart httpd
- name: apache service runs
service: name-httpd state=started
handlers:
- name: restart httpd
service: name=httpd state=restarted
Adding NTP deployment tasks to /etc/ansible/roles/web/tasks.main.yml
---
- include_vars: "{{ ansible_os_family }}.yml"
- name: Deploy Apache for Red Hat systems
yum: pkg-httpd state=latest
when: ansible_os_family' == 'RedHat'
- name: Deploy Apache for Debian systems
apt: pkg=apache2 state=latest
when: ansible_os_family == 'Debian'
- name: Apache Config File
copy: src={{ conffile }} dest={{ confpath }}
notify:
- config file update
- name: Apache Service Runs
service: name={{ webserver }} state=started
- name: Deploy NTP on Ubuntu servers
apt: pkg=ntp state=latest
when: ansible_os_family == 'Debian'
- name: Deploy NTP for Red Hat systems
yum: pkg=ntp state=latest
when: ansible_os_family == 'RedHat'
- name: NTP Service Runs
service: name={{ ntpserver }} state=started
Isilon
isi_for_array –s isi_hw_status –i
isi_for_array "isi devices"
isi_for_array -s isi devices | grep -vi healthy
isi_for_array -n 15 isi devices
isi events
isi services -la
isi status
isi statistics pstat
isi statistics drive
isi statistics client
--orderby=Ops --top
isi statistics system --nodes --top
isi statistics client --orderby=Ops --top --long
isi statistics system --nodes --top
isi statistics client --orderby=Ops --top --long
isi statistics heat --top
isi perfstat
isi job status –v
isi job list
isi_hw_status
isi_hw_status | grep SerNo
For CPU performance:
isi statistics system --top --nodes --interval=5
isi_for_array -s isi_hw_status | grep -i 'power sup'
isi networks
For checking latency:
sysctl -aN hw.iosched | grep bios.inqueue | xargs sysctl -D
For checking latency:
sysctl -aN hw.iosched | grep bios.inqueue | xargs sysctl -D
isi get -a /ifs/data
isi devices
isi devices
isi license
isi job events list --job-type dedupe
isi dedupe settings view
isi dedupe reports list
isi dedupe stats
isi auth ldap list
isi services
isi smb log-level
gmirror status
isi quota quotas list
isi quota quotas list --path=<path> -v
isi quota quotas view <path> directory
isi batterystatus
isi firmware status
isi nfs exports list
isi nfs exports view <number>
isi networks list interfaces
isi networks list pools
isi networks list rules
isi networks list subnets
netstat -an
atacontrol list
isi_cache_stats -v
isi get /ifs
isi_radish -a
netstat -an
atacontrol list
isi_cache_stats -v
isi get /ifs
isi_radish -a
Subscribe to:
Posts (Atom)